• I installed quill to check it out in a forum that is not in production yet. I didn’t save a single post into the database (I know it stores html, not markdown). I then proceeded to remove it. Not only deactivated, but also uninstalled the plugin. I don’t see the plugin on plugins. I pressed ‘rebuild and restart forum’,

    Yet I still see it on the dropdown list of plugins:
    1f02c3f1-919d-4964-b7fb-deb415396f9f-image.png

    And when I try to post, I get the quill interface, not the default one.
    My guess is that the forum didn’t ’ ‘rebuild and restart.’

    How can I test this hypothesis? Anything else you would test?


  • @qwinter yes. I’d test by using the cli, so npm remove nodebb-plugin-xxx (where xxx is the plugin name or identifier). I’ve had this before myself so took this route which solved the problem.


  • @phenomlab said in Moving away from the quill.js plugin:

    npm remove nodebb-plugin

    Thanks @phenomlab . I tried that but got:

    npm WARN reify Removing non-directory /app/code/node_modules
    npm ERR! code EROFS
    npm ERR! syscall unlink
    npm ERR! path /app/code/node_modules
    npm ERR! errno -30
    npm ERR! rofs EROFS: read-only file system, unlink '/app/code/node_modules'
    npm ERR! rofs Often virtualized file systems, or other file systems
    npm ERR! rofs that don't support symlinks, give this error.
    

    As root (on a cloudron install of nodebb, so I imagine it’s a docker env).
    Any idea what could be wrong?

    The comporser that shows up when trying to post is quill.js. But I get this error too:

    ×ERROR
    Invalid event: plugins.composer-quill.getEmojiTable
    

    Wow, it looks like the plugin situation with nodebb is a minefield. Barely touched the install and it’s already giving me hard-to-debug problems. Perhaps the best way to go is to start from scratch, and make it mega-vanilla, no plugins whatsoever 🙂


  • @qwinter which version of NodeBB is this ?


  • @phenomlab NodeBB 2.0.0


  • @qwinter That’s likely the reason why. That version is buggy presently.


  • @phenomlab thanks so much. This saves so much time. Argh. I’m running nodebb on cloudron. And they push versions to production whenever they feel like (quite fast I must say). They don’t track whether the app is buggy on that version it seems.

    That means that any time they could break my production site without me doing anything. I’m glad I realized this before going any further.


  • @qwinter yeah, it was pretty broken when I checked it last around a week ago - it was so bad in fact, that I landed up rolling back to 1.19.7 in my Dev environment.

    Version 2.0 is quite the departure as it uses webpack. I’ve seen on GitHub that 2.01 is in the works which I think it’s going to fix (hopefully) these issues. From my perspective, I will remain on the 1.19.7 train for a while as 2.0 is currently a little too bleeding edge for my liking.

    Plus, there are several plugins that I’d consider essential that need to be made compatible with the latest release.


  • @phenomlab This is really disappointing. I think I’m jumping off the train of self-hosting with cloudron. Not having control over this is really askng for trouble.
    Because self-hosting is done by people who don’t have a sysadmin on call, and they don’t want to deal with these things (hence cloudron!), dropping a broken version on an app on the user’s lap is a guaranteed pain in the neck for the self-hoster. Imagine this was a live, active forum. Going back to previous version would lose some posts. And the users would be pissed if they lost a big post.

    Yes you can be very systematic with backups. Yes you may be on top of things and act fast. Yes you can read the forums for the apps you self-host. But then you have an extra job, one you don’t want to have. If you just want to run a community, dicking around with versions and configs is not a good use of your time. This is how we got to the situation we are in: everyone is hostage of apps, bigTech, and ‘convenience’. Because the alternative is just freaking terrible. And I thought cloudron would solve this… they are not made of magic I guess. You still have to babysit your sites, read updates on forums for your apps, etc. Not worth it, sorry.


  • @qwinter I think most of the issues stem from 2.0 to be fair - 1.19.7 is stable with zero issues for me. What issues are you experiencing ?

    I self host with Hetzner, and have no issues at all.


  • @qwinter I’m interested in picking this up again as it seems the conversation went stale.

    Any updates from your side ?


  • It’s worth adding @qwinter that 2.x is now completely stable.



Discover More