@Sala I’ve spent some time this morning reviewing your WordPress configuration. The issue of the duplicated h1 tag is being caused by AnsPress - you’ll no doubt recall I warned against using this “plugin” (if you can call it that - it’s terrible) here

https://sudonix.com/topic/358/fresher-in-nodebb-install/6?_=1674640646763

AnsPress is well-known in WordPress circles for being one of those plugins you’d avoid at all costs. I used it once - never again. It causes far too many issues, and provided you don’t mind your site suffering as a result in terms of performance, bugs, and the like, then ok. In relation to SEO, see the below

SEO Issues – AnsPress

This was reported in October 2022, and it’s still not fixed.

From my own independent review, I also see the following issues

81a553b7-acac-43ab-baeb-13d956c41d5f-image.png

The most damaging of these is content being served on both non-www and www URLS, which needs to be fixed ASAP. You’ll note that the h1 heading appears twice (which you’re already aware of)

8065709b-6664-4a50-9cd4-2ca1e9dbe756-image.png

However, aside from SEO, I see far more important issues that you need to resolve first

TTFB (Time to First Byte) - the page is incredibly slow to load - in some cases, it takes 2-3 seconds before any content is shown. This is a killer in itself as more than one second loading time is considered far too high. 301 redirects are missing - in this case, you should have a global redirect so that the content is being served from the same domain at all times.

The bottom line here, and the “fix” is to remove AnsPress. Clearly, this isn’t palatable from your perspective as there is significant investment on your side. I know from previous discussions that AnsPress was shipped with the theme you are using, but it’s a below-par plugin in terms of performance and stability.

You’ll see below my attempts to get AnsPress working as far back as 2017 - I promptly gave up, because it was such a mess

Nov 4, 2017 AnsPress Plugin with X Pro (Integrity Stack) AnsPress Plugin with X Pro (Integrity Stack)

Hi. I am using X Pro and am having an issue with AnsPress displaying properly. I know this is theme related, as if I switch to TwentySeventeen, the pages work as intended. As an example - https://www.phenomlab.com/comminuty/category renders correctly, but anything underneath just shows a blank...

And finally, one very well respected WordPress resource (wpcrafter.com) parted ways with AnsPress in 2018 for similar reasons, which he clearly stated

Very serious issue with upgrade to v4.1.9 Multiple emails being sent out to everyone – AnsPress

262370bb-7d2b-499e-9d89-fac759b1e42d-image.png

At this point, I would weigh up the investment in AnsPress and seriously consider removing it.